INCA-SIP V7.1
User’s Guide
Copyright

The data in this document may not be altered or amended without special notification from ETAS GmbH. ETAS GmbH undertakes no further obligation in relation to this document. The software described in it can only be used if the customer is in possession of a general license agreement or single license. Using and copying is only allowed in concurrence with the specifications stipulated in the contract.

Under no circumstances may any part of this document be copied, reproduced, transmitted, stored in a retrieval system or translated into another language without the express written permission of ETAS GmbH.

© Copyright 2015 ETAS GmbH, Stuttgart

The names and designations used in this document are trademarks or brands belonging to the respective owners.

Document AM012001 V7.1 R05 EN - 03.2015
## Contents

1 Introduction ................................................................. 5  
1.1 About this Manual ...................................................... 6

2 New Features in INCA-SIP .................................................. 7  
2.1 New Features in INCA-SIP V7.1 .......................................... 7  
2.1.1 Time Raster Support .................................................. 7  
2.1.2 Simulink Accelerator Mode Support ................................. 9  
2.1.3 Measurement and Calibration in S-Function DLLs .................. 10

3 Installation ....................................................................... 13  
3.1 System Requirements ..................................................... 13  
3.1.1 Hardware Requirements .............................................. 13  
3.1.2 Software Requirements .............................................. 13  
3.2 Installation ................................................................. 14  
3.2.1 Installing INCA-SIP V7.1 ............................................ 14  
3.2.2 Registering a C Compiler ........................................... 16  
3.2.3 Start Menu .............................................................. 16  
3.3 Licensing the Software ................................................... 17  
3.4 Files and Directories ...................................................... 18  
3.5 Uninstallation ............................................................. 19

4 Working with INCA-SIP V7.1 .............................................. 20  
4.1 MATLAB Versions and Search Path Modification ................. 20  
4.2 Preparation .............................................................. 20  
4.2.1 Adding the INCA-SIP Block to your Model .................... 20  
4.2.2 Customizing the INCA-SIP Block ................................ 22  
4.3 How INCA-SIP Works .................................................. 28  
4.3.1 Validating the Current Model ................................. 28  
4.3.2 Connecting the Model ............................................. 28  
4.3.3 Model Analysis .................................................... 28
4.3.4 Selecting the Functions to be Used ........................................ 29
4.3.5 Measurement and Calibration .............................................. 29
4.3.6 Measurement Modes ........................................................ 30
4.3.7 Disconnecting the Model ................................................... 30
4.3.8 Updating the INCA ECU Project on Model Changes .............. 30
4.4 Tutorial ................................................................................. 32
4.5 Restrictions and Other Behavior ............................................. 38
  4.5.1 Connecting to and Disconnecting from INCA ...................... 38
  4.5.2 RAM Calibration .............................................................. 38
  4.5.3 Parallel Measurements with other Hardware ...................... 38
  4.5.4 Pausing Measurements .................................................... 38
5 Engineering Services for Customized Model Integration ............... 39
6 ETAS Contact Addresses ........................................................ 40
Index ......................................................................................... 41
1 Introduction

INCA-SIP V7.1 (INCA Simulink Integration Package) is an INCA add-on that provides measurement and calibration access to MATLAB/Simulink-modeled ECU functions via INCA.

Effectively it is a Simulink tool box – after installation a new menu-item is available in Simulink, with which a connection between INCA and the model (opened in the Simulink Model Editor) can be established.

INCA-SIP creates INCA objects (A2L, Hex, INCA workspace) from the model. Most of the models can be connected out-of-the-box; customer-specific modeling rules may require a customization.

Connecting the Simulink Model to INCA

When connecting to the model, INCA-SIP starts an analysis of the model blocks (see Fig. 1-1, upper part). This analysis can be customized to deal with customer-specific modeling guidelines. This customization is only required once, when INCA-SIP is introduced.

All parameters required for M/C access are determined and all artifacts required by INCA are generated.

M/C of the Model

For measurement and calibration, INCA views INCA-SIP as an ordinary XCP device – INCA-SIP exchanges data with the model via MATLAB’s IMLApp interface (see Fig. 1-1, lower part). Measurement and calibration can be done while Simulink runs the model.

Fig. 1-1 Analyzing the Model (Upper Part) and M/C Access (Lower Part)
1.1 About this Manual

This manual addresses qualified personnel working in the fields of automobile ECU development and calibration. Specialized knowledge in the areas of measurement and control unit technology is required. Moreover, users need to be able to work with INCA and know the basic functionality of INCA.

The INCA-SIP V7.1 manual consists of the following chapters:

- "Introduction" on page 5
  This chapter
- "Installation" on page 13
  This chapter contains information on system requirements and on installing and licensing INCA-SIP V7.1.
- "Working with INCA-SIP V7.1" on page 20
  This chapter contains information on preparatory measures, a description of how to work with INCA-SIP and a tutorial demonstrating how to operate INCA-SIP using a simple Simulink model.
- "Engineering Services for Customized Model Integration" on page 39
  ETAS offers engineering services to further customize the generation of the ASAP2 file information to reflect specific customer needs.
2 New Features in INCA-SIP

This section contains a summary of the new features that have been introduced in INCA-SIP. You should read this section even if you are already an experienced INCA-SIP user.

2.1 New Features in INCA-SIP V7.1

2.1.1 Time Raster Support

Simulation performance in Simulink depends on the Simulink solver settings and particularly on the step size for fix-step solvers – precise simulation often requires step sizes of 1 ms.

INCA-SIP up to V7.0 transfers data from Simulink to INCA at every solver step. Transferring data involves significant communication and visualization effort to and within INCA. INCA cannot acquire data at such speed and INCA-SIP will slow down simulation in Simulink to avoid data loss. However, for the measurement and calibration of embedded control systems it is often sufficient to acquire data in intervals of 10 - 100 ms.

INCA-SIP V7.1 introduces a time raster to minimize data transfer and maximize measurement performance during simulation. The time raster defines different time intervals at which measurement data will be collected from the model – they are defined in the "INCA-SIP ECU Properties" window (see "Measurement Events" on page 26).

(Note: The time raster needs to be a multiple of the Simulink simulation step size!)
Signals can be assigned to a time raster in INCA as usual.

Note
At high data rates, INCA oscilloscopes are unsuitable for display. Please use MDF recording instead.

Example:
Model time (in seconds) simulated in a stimuli and PID control experiment (30-second real-time simulation).

<table>
<thead>
<tr>
<th>Simulink w/ Fix-step 0.001</th>
<th>SIP Realtime-Simulation</th>
<th>SIP Fast-Simulation</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>SIP Measurement w/o raster</td>
<td>SIP Measurement 100ms raster</td>
</tr>
<tr>
<td>550</td>
<td>30</td>
<td>150 400</td>
</tr>
</tbody>
</table>
2.1.2 Simulink Accelerator Mode Support

MATLAB Simulink provides two simulation modes for fast simulation:

- **Accelerator Mode**
  In Accelerator Mode, Simulink performs an internal optimization prior to simulation.

- **Rapid Accelerator Mode**
  In Rapid Accelerator Mode, a Windows executable is generated for fast simulation.

For further details please refer to the Simulink documentation.

INCA-SIP hides the technicalities from the user and supports both concepts without there being any changes to the model.

Add the INCA-SIP block to the model, connect to INCA, change the simulation mode in Simulink and start measurement and calibration with INCA.

**Note**

*For Accelerator Mode and Rapid Accelerator Mode it is essential to use the time raster to minimize communication overhead. Otherwise you will not notice the performance increase in INCA-SIP.*
2.1.3 Measurement and Calibration in S-Function DLLs

Simulink S-function technology enables simulation models to include Windows dynamic link libraries (DLL). S-functions provide defined in- and outports, which can be accessed by INCA-SIP – any information within a DLL is not accessible to Simulink or INCA-SIP.

In automotive control system simulations such S-functions often represent embedded control logic to be simulated within a Simulink experiment. These control logic S-functions contain measurement signals and calibration labels.

The new feature introduces an interface which enables description of the memory layout and offsets of measurement signals and calibration labels.

INCA-SIP will include this information in the generated A2L file and allows calibrators to measure signals and modify labels within such S-functions.

The following directory contains an example:

```
<drive>:\ETASData\INCA-SIP\SIPDLLDemo
```

![Example Model with S-Function Block](image)

**Fig. 2-1** Example Model with S-Function Block

- Double-click the S-function block.

  The "Function Block Parameters" window opens.
- Click **Edit**. The code of the S-function interface is displayed in the editor.

**Fig. 2-2** Source Code of the S-Function Interface

**Fig. 2-3** The DLL's Source Code
**Build Process**

INCA-SIP parses the Simulink model and generates an A2L file when you connect to INCA. For every DLL, INCA-SIP includes a `<dllname>.sincamerge` file into A2L generation – this file describes signals and parameters for a DLL.

**Note**

ETAS supports built-in LCC and Microsoft Visual Studio® for the S-function® build procedure. If you want to use a different compiler, please ask about engineering services (see “Engineering Services for Customized Model Integration” on page 39).
3 Installation

This chapter contains information about the installation of the program, e.g. system requirements, licensing, and files and directories.

3.1 System Requirements

To work with INCA-SIP V7.1 the following requirements must be fulfilled.

3.1.1 Hardware Requirements

The hardware requirements for the add-on are the same as for INCA and MATLAB/Simulink (please refer to the respective manuals).

3.1.2 Software Requirements

To work with INCA-SIP V7.1 you need the following software:

- INCA 7.1 including current hotfixes
- MATLAB/Simulink
  Please see the release notes for the supported versions of MATLAB/Simulink.
3.2  Installation

In this section you will find a description of the installation procedure and additional information about start menu entries and MATLAB path modifications.

3.2.1 Installing INCA-SIP V7.1

This section describes how to install INCA-SIP V7.1.

To execute installation

• Insert the product CD in your CD-ROM drive.
  The CD browser is launched.
• Select **Main**, then select whether you want to install INCA-SIP for INCA 7.0 or for INCA 7.1.

• Follow the instructions given on the screen.

Most of the screens are completely self-explanatory. The following section explains only those parts of the installation procedure where additional information might be helpful.
32-bit- and 64-bit INCA-SIP installation

If you are installing on a 64-bit Windows, both 32-bit- or 64-bit versions will be installed (in separate directories).

Both versions will run properly on a 64-bit system. However, the 32-bit version of INCA-SIP will only work with 32-bit versions of MATLAB/SIMULINK, and the 64-bit version of INCA-SIP will work only with the 64-bit versions of MATLAB/SIMULINK.

For more information, refer to "MATLAB Versions and Search Path Modification" on page 20.

**Note**

On a 32-bit system, only the 32-bit version of INCA-SIP can be used. Therefore only that version will be installed automatically.
3.2.2 Registering a C Compiler

Using INCA-SIP requires a C compiler registered as a mex compiler with MATLAB. All 32-bit versions of MATLAB come with a built-in ‘lcc’ compiler that is automatically registered as a mex compiler during MATLAB installation. Therefore no compiler configuration is necessary to begin using INCA-SIP with 32-bit MATLAB, unless a compiler other than ‘lcc’ is desired.

64-bit MATLAB does not come with a built-in compiler. Therefore, prior to using 64-bit INCA-SIP it is necessary to register an external compiler, such as Visual Studio, as a mex compiler. This is done by running ‘mex -setup’ in the desired 64-bit MATLAB version before using INCA-SIP.

If both 32-bit and 64-bit installations of the same MATLAB version are present on the machine, 32-bit INCA-SIP will work with the 32-bit version and 64-bit INCA-SIP will work with the 64-bit version. However, when switching between these two versions, it is necessary to rerun ‘mex -setup’ in the desired MATLAB version every time a switch is made, prior to using INCA-SIP.

3.2.3 Start Menu

The Start menu folder All Programs → ETAS → INCA-SIP 7.1 contains the following entries once installation has been completed successfully:

- **Manuals and Tutorials**
  
  Opens a folder containing this manual and other useful information

- **ReadMe and Licenses**
  
  Contains the readme.txt and license.txt file
3.3 Licensing the Software

A valid license is required for using INCA. You can obtain the license file required for licensing either from your tool coordinator or through a self service portal on the ETAS Internet Site under http://www.etas.com/support/licensing. To request the license file you have to enter the activation number which you received from ETAS during the ordering process.

In the Windows Start menu, select Programs → ETAS → License Management → ETAS License Manager.

Follow the instructions given in the dialog. For further information about, for example, the ETAS license models and borrowing a license, press F1 in the ETAS License Manager.
3.4 Files and Directories

During installation you select two directories: one for the executable, M-scripts etc. (default: `<drive>:\ETAS\INCA-SIP7.1`) and another one for the data files (default: `<drive>:\ETASData\INCA-SIP7.1`).

**MATLAB Script Files**

Much of the functionality of INCA-SIP is implemented as MATLAB scripts to facilitate customization and debugging in the field.

The folder `\ETAS\INCA-SIP7.1\M-Scripts` contains MATLAB script files that are either called by INCA-SIP or are used by Simulink to interact with INCA-SIP and INCA.

**Data Files**

Data files for the INCA-SIP application are installed in `<drive>:\ETASData\INCA-SIP7.1`. 
3.5 Uninstallation

You can uninstall INCA-SIP via the Windows Control Panel → Programs and Functions.

If INCA-SIP was installed using an INCA service pack, it will be uninstalled with INCA.
4 Working with INCA-SIP V7.1

This chapter contains information on preparatory measures, a description of how to work with INCA-SIP and a tutorial demonstrating how to operate INCA-SIP using a simple Simulink model.

4.1 MATLAB Versions and Search Path Modification

INCA-SIP can be used with any MATLAB version installed on the PC. To make INCA-SIP available in a particular MATLAB version, you must add the INCA-SIP installation path using the MATLAB command "Add path" followed by "Save path".

For 32-bit versions, the INCA-SIP installation path is typically C:\ETAS\INCA-SIP7.1\Win32.

For 64-bit versions, the INCA-SIP installation path is typically C:\ETAS\INCA-SIP7.1\x64.

4.2 Preparation

Before you can calibrate and measure with INCA, you must add the INCA-SIP block to the model. This block is needed to create an ASAP2 description of the model and to connect the model to INCA via XCP.

4.2.1 Adding the INCA-SIP Block to your Model

- Start MATLAB.
- The MATLAB desktop opens.
- Select the directory containing your model.
The content of the directory selected is displayed in the “Current Folder” field.

- Double-click a model (.mdl).
  The model is displayed in an instance of the Model Editor.
- Select **Tools → INCA-SIP → Add INCA-SIP**.
  The block “INCASIP” is added to the model.

This block enables you to create an ASAP2 description of the model and to connect the model to INCA via XCP.
4.2.2 Customizing the INCA-SIP Block

- In the Simulink model window, double-click the INCA-SIP block. The “INCA-SIP System Properties” window opens.

These values (taken from the INCASIP.defaults file) are loaded into the INCA-SIP block when it is first added to a model. After that, any edits made in the above dialog are stored in the block (within the .mdl file) – **not** in the defaults file.

**Dialog Options and Files Settings**

- **Simulation Group**
  Name of the INCA workspace as it will appear in the INCA Database Browser. Default is `<Model Name>_wsp`.

- **Load Stimulus from MDF File**
  Selection box that enables or disables MDF stimulus import.

- **MDF Stimulus File**
  Name of the MDF file from which the stimulus values will be read.

- **MDF Stimulus Mapping File**
  XML file where the MDF signal to Simulink block mapping will be stored. If the file does not exist, or is not a valid XML file, a new file will be created with a default mapping. The default mapping will attempt to match MDF signals to Simulink blocks based on names. A case insensitive comparison will be made between the MDF signal (without the device name) and the Simulink blocks names. If this comparison is true, a mapping will be made for that signal/block pair.
• **Edit MDF Stimulus Mapping**
  Button that opens the MDF signal to Simulink block mapping dialog (for details see "MDF Signal to Simulink Import Mapping" on page 24 below).

• **INCA Database**
  Location of the INCA database to be used. You can specify any folder you wish here and INCA will create a new database there if one does not already exist.

• **INCA Folder**
  Path within the INCA database where the workspace and ECU project will be created. Default is "INCASIP\<Model Name>".

• **INCA Dataset Export Format**
  This is the output format that will be used for CDM.
  If you make a change to the model and the INCA-SIP ECU project no longer matches the model, users will be asked when they connect if they would like to export the current dataset(s) when they connect to INCA-SIP.
  This is asked because INCA-SIP needs to re-create the ECU project and the datasets (because the virtual addresses of parameters and variables have changed). Once the ECU project is re-created, the user can then use the exported (ASCII, HTML, DCM, CVX) file to get his/her working dataset back.

• **View INCA-SIP ECU Blocks**
  Opens the sub-system containing the INCA-SIP ECU descriptions (for details see "Modification of ECU Parameters" on page 25 below).
MDF Signal to Simulink Import Mapping

Drag items from the right side to the left to create a mapping.
Alternately, select a Simulink block item on the left side then select an MDF signal on the right and use the arrow keys in the center to map or unmap the Simulink block.
Modification of ECU Parameters

In the “INCA-SIP System Properties” window (see “Customizing the INCA-SIP Block” on page 22) click View INCA-SIP ECU Blocks.

The block is opened.

Double click on an ECU to modify ECU parameters.

The following dialog is opened.

In this window the following properties can be defined:

- **Regenerate SIP Description, ASAP and Hex Files**
  
  If checked, the description file (*.sipd), the ASAP2 file (*.a2l) and the hex file (*.s19) are generated every time you connect to the model. If you are not actively making changes to a model’s structure, you would un-check this box. This saves time especially when working with large models.
- **Description File**
  This is the location and name of the INCA-SIP description file (*.sipd, an XML file).
  This file contains the ASAP2 description of the model's parameters and variables as well as information necessary to modify and access these objects in MATLAB/Simulink.

- **ASAP2 File**
  Location and name of the ASAP2 file (*.a2l) generated for this model.

- **Hex File**
  Location and name of the Motorola S-Record hex file (*.s19) generated for this model. This file contains the base-line calibration values found when the model is connected (if **Regenerate SIP Description, ASAP and Hex Files** (see page 25) is on, this file will be regenerated each time you reconnect).

- **Measurement Events**
  Here the different time intervals are defined at which measurement data will be collected from the model. A minimum of one event and a maximum of eight events can be defined.
  The user can add (**Add Event**) and remove events (**Delete Event**) and modify the name, type and interval of event (**Edit Event**).

  - **Event Name**
    The name of the event as it will be displayed in the INCA variable selection dialog. Numbers, letters, underscores, decimal points and spaces are valid characters.

  - **Synchronous Event**
    A checkbox that, when selected, adds an input port to the event that must be driven by a **fcn_call** signal somewhere within the model. This allows the user to configure a measurement that can be triggered by some condition within the model (not just at a specific time interval).

  **Note**
  *When using a synchronous event, the "Event Sample Time" must be set to match the sample time of the source of the **fcn_call** signal.*
– **Event Sample Time**
  A double-precision floating-point number representing the interval (in seconds) at which data will be collected for the event. The value 0 is a valid setting and represents a continuous sampling that will occur with each simulation step. Otherwise, any positive, real value is valid.

- **Calibration Block Types**
  These are the M-functions that find all the calibrations in the model.

- **Measurements**
  These are the M-functions that find all the measurements in the model.
4.3 How INCA-SIP Works

This section contains a description on how you can work with INCA-SIP.

4.3.1 Validating the Current Model

The purpose of model validation is to determine whether the model can be connected to INCA via INCA-SIP. All errors discovered during model validation are summarized in a message box at the end of the validation and recorded in a text file for future analysis. To validate the Simulink Model, select Tools → INCA-SIP → Validate the Current Model in the Simulink Model Editor, which will:

- Verify that the model has no missing connections or orphaned blocks
- Verify that all library links within the blocks have been disabled
- Verify each measurement’s compliance with the INCA-SIP object model for measurements
- Verify each calibration’s compliance with the INCA-SIP object model for calibrations
- Verify each calibration segment’s compliance with the INCA-SIP object model

Depending on the size of the model, validation can take anywhere from a few seconds to several minutes. Performing model validation ensures, however, that all potential connection problems are identified and reported at once, rather than one problem per connection attempt.

4.3.2 Connecting the Model

To connect the Simulink model, select Tools → INCA-SIP → Connect/Reconnect to Current Model in the Simulink Model Editor, which will:

- Launch the INCA-SIP server (if not started already)
- Launch INCA (if not started already)
- Create the INCA folders, workspace and ECU project specified in the model description file in INCA (if not created already)
- Configure the INCA-SIP server with the model description file (*.sipd)
- Start the XCP server

**Note**

*If the model does not match the ECU project, the ECU project will be recreated.*

4.3.3 Model Analysis

To create an ASAP2 description for a Simulink model, the model must be analyzed to find calibration and measurement objects. This analysis will be performed by M-Script search functions.

The search for calibrations and measurements within a Simulink model or MATLAB workspace will be performed by two MATLAB M-functions (referred to as "find calibrations" and "find measurements"). Both functions take a single argument: the name of the Simulink system (model name).
A reference implementation of these functions is provided by ETAS. This reference implementation can be freely modified and adapted by the end user as long as the resulting output structures contain all of the required fields.

The MATLAB search functions to be applied can be selected in the "INCA-SIP Properties" window of the INCA-SIP block. To open this window double-click the block or select Open Block from the context menu of the block.

4.3.4 Selecting the Functions to be Used

The MATLAB search functions to be used can be clicked and selected in the "INCA-SIP Properties" window of the INCA-SIP block.

Multiple selection is possible by keeping the <SHIFT> key pressed down; you can deselect a single item by keeping the <CTRL> key pressed down.

For information on how to customize search functions refer to the chapter "Engineering Services for Customized Model Integration" on page 39.

4.3.5 Measurement and Calibration

Once INCA-SIP and INCA are launched and initialized, calibration and measurement are possible via the INCA experiment environment.

Please note the following restrictions:

- **Measurement values**
  Signals that are contained within Simulink Library blocks cannot be measured unless the library link is disabled. The INCA-SIP scripts display a dialog warning to the user if measurements have been found within any enabled library blocks giving the user a chance to disable them.

- **Calibration values**
  There may be MATLAB objects for which updates are not picked up by the simulation if they occur during simulation. The value is modified, but the effects will not be seen until the next simulation run.

*Simulation and Measurement*

When measurement or recording is started in INCA, the model simulation (in Simulink) is started automatically. When the simulation ends and measurement is re-started in INCA, the simulation is started again (from time 0) in Simulink.

**Note**

Starting the simulation from within MATLAB/Simulink does not start measurement or recording in INCA. If INCA measurement/recording is started after simulation has been started within MATLAB/Simulink, data may be lost!

Stopping the measurement or recording in INCA does not stop the simulation in Simulink.
**Simulation and Calibration**

When the simulation is running, calibration via INCA is possible – this applies only to built-in Simulink blocks Constant, Lookup, Lookup2D, and Lookup3D.

Customized blocks do not necessarily work with online calibrations – engineering project enhancements would be needed to enable this (see "Engineering Services for Customized Model Integration" on page 39).

4.3.6 Measurement Modes

INCA-SIP allows the model to simulate in two modes thus allowing the user to perform calibrations in different ways during simulation. These two modes are referred to as "Real-Time Emulation Mode" and "Fast Emulation Mode".

**Real-Time Emulation Mode**

In this mode the simulation of the model is throttled to near real-time if the model would normally simulate faster than real-time. In turn, if the model simulates slower than real-time, the selection of this mode has no effect on the simulation.

This mode is used when the user would like to calibrate the model during simulation and visualize the effects of the calibration on the simulation. To enable/disable this mode (after connecting and before running the experiment), select Tools → INCA-SIP → Measurement Mode → Real-Time Emulation Mode.

**Fast Emulation Mode**

In this mode INCA-SIP transmits data to INCA as fast as is possible (without INCA losing data) during simulation.

This makes it difficult to visualize data, but for this mode, the use case is to make offline calibration changes and then simulate the model for a fixed period of time. This simulation should occur very fast and the measure data can then be analyzed offline (MDA).

To enable/disable this mode (after connecting and before running the experiment), select Tools → INCA-SIP → Measurement Mode → Fast Emulation Mode.

4.3.7 Disconnecting the Model

To disconnect the Simulink model, select Tools → INCA-SIP → Disconnect from Current Model in the Simulink Model Editor. This invokes a function which will stop the XCP server and finally unload the configuration that was created with the model description file.

**Note**

*For MATLAB versions 2012b and greater, you must stop the running model before you can disconnect.*

4.3.8 Updating the INCA ECU Project on Model Changes

If changes are made to the Simulink model when it is connected to INCA, you may reconnect with the changes then taken into account. After applying changes to the Simulink model, select Tools → INCA-SIP → Connect/Reconnect to Current Model.
INCA then disconnects from the model, and reconnects again. The changes of the model are recognized and the ECU project is updated.
4.4 Tutorial

In this tutorial, you use a simple example to learn how to operate INCA-SIP. To do so, you use the SIPDemo.mdl model that (together with other files) is placed in the directory

<drive>:\ETASData\INCA-SIP7.1\SIPDemo

when INCA-SIP is installed.

The following steps are executed:

- "To connect to the model" on page 32
- "To run the experiment" on page 34
- "To make changes to the model" on page 38

To connect to the model

- Start MATLAB.
- In the MATLAB desktop select the directory containing your model.
- The content of the directory selected is displayed in the "Current Folder" field.

- Double-click sipdemo.mdl.
- The model is displayed in an instance of the Model Editor.
• Select **Tools → INCA-SIP → Add INCA-SIP**.

The block is added to the model.

This block enables you to create an ASAP2 description of the model and to connect the model to INCA via XCP.

• In the Model Editor’s menu select **Tools → INCA-SIP → Connect/Reconnect to Current Model**.

The model is examined, calibration and measure variables are determined and an XML file containing the model description is created.
Then INCA is started and a folder (within the “INCASIP” database), a workspace and an ECU project are created.

To run the experiment

- Select the “sipdemo_wsp” workspace.
- Select Experiment ➔ Run experiment.
- Press <RETURN>.
  The INCA experiment environment opens.
- Select Variables ➔ Variable Selection.
  The “Variable Selection” window opens.
• Select the measure variable "SineWaveOutput".

• Right-click the measure variable and select Add to... → Layer_1 → New... → YT-Oscilloscope.
• Click **OK**.
  A YT oscilloscope is created.

• Select **Experiment → Save**.
  • In the following window, select the folder "sipdemo" and enter a name ("DemoExperiment") for the experiment.
• Click **OK**.

The experiment is saved in the folder of the “INCASIP” database.

• Start the measurement in the experiment environment by clicking **Measurement → Start Visualization**.

  or

• Click the **Start Visualization** icon.

The simulation in Simulink and the measurement in INCA is started and displayed in the YT-oscilloscope.

• Stop the measurement in INCA by clicking **Measurement → Stop Measuring**.

  or

• Click the **Stop Measuring** icon.

The measurement in INCA is stopped.

• To stop simulation in Simulink select **Simulation → Stop** in the Model Editor.
To make changes to the model

- Click **Tools → INCA-SIP → Disconnect from Current Model** in the Model Editor.
  This will close the connection to the model.
- Make your changes to the Simulink model and save it.
- In the Model Editor select **Tools → INCA-SIP → Connect/Reconnect to Current Model**.
  The ASAP2 description of the model is re-created and in turn the ECU project in INCA is updated.
- To close the experiment environment click **OK**.

### 4.5 Restrictions and Other Behavior

This section contains a range of tips and information on restrictions and behavior of INCA-SIP V7.1

#### 4.5.1 Connecting to and Disconnecting from INCA

When you connect to INCA or disconnect from INCA while a simulation is running (in Simulink), the simulation is always terminated.

**Note**

*For MATLAB versions 2012b and greater, you must stop the running model before you can disconnect.*

#### 4.5.2 RAM Calibration

RAM calibration is not supported in INCA-SIP V7.1.

#### 4.5.3 Parallel Measurements with other Hardware

When INCA-SIP V7.1 is connected to a Simulink model, it is not possible to measure and calibrate with other devices.

#### 4.5.4 Pausing Measurements

If you use the "Pause Recording" function in INCA, you may notice in the subsequent measure data analysis in MDA that there is no data or data has been interpolated over extended areas.

This behavior deviates from that of measure hardware in which a paused measurement in the measure file is displayed in the form of breaks of 1 s.
5 Engineering Services for Customized Model Integration

ETAS offers engineering services to further customize the generation of the ASAP2 file information to reflect specific customer needs. This does have a direct impact on the measure and calibration variables available in the INCA experiment and on their attributes. Services include but are not restricted to:

- Support of customer-specific data types
- Specific search functions to determine relevant measure and calibration values according to customer modeling rules
- Support of additional optional ASAP2 attributes relevant to the customer

In addition to customizing the search functionality, ETAS offers additional services to further integrate the INCA-SIP product into the customer’s development process.

For more information about engineering services related to the INCA-SIP product contact your local sales representative.
6 ETAS Contact Addresses

ETAS HQ
ETAS GmbH
Borsigstraße 14
70469 Stuttgart
Germany
Phone: +49 711 3423-0
Fax: +49 711 3423-2106
WWW: www.etas.com

ETAS Subsidiaries and Technical Support

For details of your local sales office as well as your local technical support team and product hotlines, take a look at the ETAS website:

ETAS subsidiaries
WWW: www.etas.com/en/contact.php

ETAS technical support
## Index

| C | Calibration 29  
|   | Customized model integration engineering services 39  
| D | Directories 18  
| E | ETAS Contact Addresses 40  
| F | Files 18  
| I | INCA-SIP block  
|   | adding to the model 20  
|   | customizing 22  
|   | Installation 13  
|   | Introduction 5  
| L | Licensing 17  
| M | Measurement 29  
|   | Measurement modes 30  
|   | Model processing 28  
| S | S-Function DLLs  
|   | measurement and calibration 10  
|   | Simulink Accelerator Mode 9  
|   | Start menu 16  
|   | System requirements 13  
| T | Time Raster 7  
|   | Tutorial 32  
